Mozilla Firefox -järjestelmän vaatimukset

Mozillan kehittämä Firefox on kuin mikä tahansa muu ohjelmisto, koska se vaatii tiettyjä laitteita tai käyttöjärjestelmiä toimimaan oikein. Ennen kuin päätät vaihtaa yrityksen Internet-selaimet Firefoxiin, varmista, että olet täyttänyt järjestelmän vaatimukset. Nämä vaatimukset vaihtelevat käytetyn käyttöjärjestelmän mukaan, olipa kyseessä sitten Windows, Mac tai Linux. Tässä artikkelissa olevat tiedot ovat merkityksellisiä joulukuussa 2012.

Windows

PC-käyttäjille Mozilla suosittelee seuraavia käyttöjärjestelmiä käyttämään Firefoxia: Windows XP SP2, Windows Vista, Windows 7 ja Windows Server 2003. Vaikka Firefox toimii Windows 8: ssa, sitä ei tueta virallisesti. Lisäksi kun Windows Vista ja 7-bittiset 64-bittiset versiot voivat käyttää Firefoxia, Mozilla tukee vain 32-bittistä Firefox-versiota. Käyttöjärjestelmän lisäksi sinun on täytettävä seuraavat vähimmäislaitteistovaatimukset: Pentium 4 tai korkeampi prosessori, jossa on SSE2-tuki, 512 Mt RAM-muistia ja vähintään 200 Mt vapaata kiintolevytilaa.

mac

Mac-käyttäjille Firefox vaatii OS X 10.6: n tai 10.7: n suorittamista, ja sillä on monia samoja laitteistovaatimuksia kuin PC-versio: Intel X86 -prosessori, 512 Mt RAM-muistia ja vähintään 200 Mt vapaata kiintolevytilaa.

Linux

Linux-käyttäjille Firefoxilla on enimmäkseen ohjelmistojärjestelmävaatimuksia, joiden joukko kirjastoja tai paketteja tarvitsee toimiakseen. Nämä kirjastot tai paketit sisältävät:

GTK + 2.10 tai suurempi GLib 2.12 tai korkeampi Pango 1, 14 tai uudempi X.Org 1.0 tai uudempi (1, 7 tai suurempi on suositeltava) libstdc ++ 4.3 tai uudempi

Vaikka nämä ovat kirjastoja tai paketteja, joita Firefox vaatii, Mozilla määrittelee seuraavat kirjastot ja paketit, joita Linux-käyttäjien pitäisi saavuttaa optimaalisen Firefox-suorituskyvyn saavuttamiseksi:

NetworkManager 0.7 tai uudempi DBus 1.0 tai uudempi HAL 0.5.8 tai uudempi GNOME 2.16 tai uudempi

Mitä jos en täytä vaatimuksia?

Vaikka et täytä Firefoxin järjestelmävaatimuksia, tietokoneella tai Macilla on edelleen mahdollisuus käyttää sitä. Saatat kuitenkin kohdata hidastumista, kurjuutta, jäädyttämistä tai pitkiä latausaikoja, kun lataat verkkosivustoa. Jos käytät PC: tä tai Macia, joka ei täytä sen vaatimuksia, yritä avata useita välilehtiä tai avata muita ohjelmia selaimen käytön aikana. Linux-käyttäjille, kuten aiemmin todettiin, jos et täytä Firefoxin järjestelmävaatimuksia, se ei toimi.

Versiotiedot

Tämän artikkelin tiedot koskevat Firefoxin versiota 17. Se voi vaihdella hieman tai huomattavasti muiden versioiden tai tuotteiden kanssa.